PlanetJava
Custom Search

java-clojure-storm
[Top] [All Lists]

Re: Class not found when running storm-starter

Subject: Re: Class not found when running storm-starter
Date: Mon, 20 Aug 2012 02:31:32 -0700
That jar doesn't have the Storm jars in it, since jars you submit to a
cluster are mandated to exclude those. You can get things running locally
by adding the Storm jars to your classpath when you run the command.
On Thu, Aug 16, 2012 at 4:56 PM, Dragos Manolescu 
<[email protected]>wrote:
> Hi --
>
> I cloned the latest storm-starter and built the .jar. I am getting the
> following:
>
> ~/Repos/storm-starter% java -cp
> target/storm-starter-0.0.1-SNAPSHOT-jar-with-dependencies.jar
> storm.starter.ExclamationTopology      [22]
> Exception in thread "main" java.lang.NoClassDefFoundError:
> backtype/storm/topology/IRichSpout
> at java.lang.Class.getDeclaredMethods0(Native Method)
> at java.lang.Class.privateGetDeclaredMethods(Class.java:2442)
> at java.lang.Class.getMethod0(Class.java:2685)
> at java.lang.Class.getMethod(Class.java:1620)
> at sun.launcher.LauncherHelper.getMainMethod(LauncherHelper.java:492)
> at sun.launcher.LauncherHelper.checkAndLoadMain(LauncherHelper.java:484)
>
> There's an older query (Jan 23) about a similar problem, and the fix was
> to use storm 0.6.2 in the dependencies. The current pom file refers to
> 0.8.0 so that answer no longer applies. FWIW I've tried compiling against
> an older version (0.7.4.) which failed with compilation problems. Please
> advise.
>
> Thanks,
>
> -D
>
-- 
Twitter: @nathanmarz
http://nathanmarz.com
msgmiddle
<Prev in Thread] Current Thread [Next in Thread>
Current Sitemap | © 2012 planetjava | Contact | Privacy Policy